Monday, February 17, 2014

StoreFront error : No certificate associated with this site

I was adding second server in the server group but it was throwing error while replicating configuration

Log Name:      Citrix Delivery Services
Source:        Citrix Configuration Replication Service
Date:          2/17/2014 6:13:06 PM
Event ID:      31
Task Category: (2801)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      XXXX
Description:
An error has occured during the all server configuration update process.
Citrix.DeliveryServices.ConfigurationReplication.Exceptions.ServerUpdateConfigurationException, Citrix.DeliveryServices.ConfigurationReplication, Version=2.4.0.0, Culture=neutral, PublicKeyToken=e8b77d454fa2a856
An error occured running the command: 'Add-DSFeatureInstances'
RemoteEndpoint: net.tcp://XXX/Citrix/ConfigurationReplication

Then we also saw following  message “No certificate associated with this site” though site was https. I tried several thing like renaming url but looks like it something else

image

Finally found that certificate was saved under “Web hosting   Certificate ” whereas it must be under “Personal – Certificate “

image

Once it was placed and binding were configured

image

All the sites were green

image

After we fixed this error replication went successfully

image

5 comments:

jb blanca said...

Thanks.

jb blanca said...

Hi,

I am encountering the same issue but i did save the cert at Personal Certificates and its still saying " no cert associated with this site" at StoreFront.

I also notice that at my CertMgr.msc I dont have a folder Web Hosting certificates. Is that wrong? Do I to reinstall my CA?

Anonymous said...

Forgot to bind my https. This was helpful! Thank you!

Anonymous said...

Forgot to bind my https and this was exactly what I needed during my moment of frustration. Thanks!

Anonymous said...

Moving into Personal worked.
Thanks